the-source/shell.nix
Christine Dodrill 66ac5c9d4e version 1.0.0
Signed-off-by: Christine Dodrill <me@christine.website>
2020-12-25 11:40:03 -05:00

19 lines
430 B
Nix

let
pkgs = import <nixpkgs> { };
nur = import (builtins.fetchTarball
"https://github.com/nix-community/NUR/archive/master.tar.gz") {
inherit pkgs;
};
tex = with pkgs;
texlive.combine { inherit (texlive) scheme-medium bitter titlesec; };
in pkgs.mkShell {
buildInputs = with pkgs; [
calibre
nur.repos.mic92.pandoc-bin
tex
lua5_3
lua53Packages.lua-lsp
lua53Packages.lua-toml
];
}